- Notícias sobre segurança
- Vulnerabilities & Exploits
- Linux Flaw Affects Linux PCs, Servers, and Devices Running Android KitKat 4.4
A previously undiscovered flaw in the Linux kernel has been found, affecting “tens of millions” of Linux PCs and servers. According to researchers, the bug allows attackers to escalate local user privileges to the highest root level, and also affects devices running Android KitKat 4.4 and higher. The flaw, which dates back to 2012, affects Linux kernel versions 3.8 and later, and is found in the keyring facility where apps are allowed to store encryption keys, authentication tokens, and other sensitive security data. Once exploited, attackers could execute code on the Linux kernel and extract cached security data. As of disclosure date, security teams are investigating potentially affected devices.
Security threats to Linux have been increasing over the past few years. With the explosion of Linux-based Android devices, the mobile OS has become the most attractive target for attackers. Android’s biggest issues is its fragmentation problem—where multiple versions of Android are present and in use—which then result in many users running outdated versions of the OS that may be riddled with vulnerabilities and security flaws. Leaving users with old versions of Android pose security risks such as unpatched vulnerabilities and new features which users won’t be able to use.
Additionally, Linux-based IoT devices have been gaining traction and are increasingly being deployed in smart systems, with IoT gateways enabling connected industry solutions and services. Hence, IoT gateways and other complex devices should prioritize security.In light of the discovered Linux flaw, affected Linux and Android users are encouraged to update their systems with the latest patches. The patch is already available as source code for most Linux distributions. Opinions on the vulnerability's severity differ, and there haven't been any attacks related to it, but it's still a vulnerability that needs to be patched. Only Linux distributions using the Linux kernel 3.10 or higher are vulnerable, while the rest are only considered "theoretically" vulnerable.
Like it? Add this infographic to your site:
1. Click on the box below. 2. Press Ctrl+A to select all. 3. Press Ctrl+C to copy. 4. Paste the code into your page (Ctrl+V).
Image will appear the same size as you see above.