Vulnerability

(MS12-074) Vulnerabilities in .NET Framework Could Allow Remote Code Execution (2745030)

Publish date: November 14, 2012

CVE-2012-1895,CVE-2012-1896,CVE-2012-2519,CVE-2012-4776,CVE-2012-4777

SEVERITY

CRITICAL

//  ADVISORY DATE

14 NOV 2012


DESCRIPTION

This patch addresses vulnerabilities existing in the .NET Framework. It could allow remote code execution once a remote attacker lures users into using malicious proxy auto configuration file and injects malicious code into any running applications.

SOLUTION

AFFECTED SOFTWARE AND VERSION

  • Windows XP Professional x64 Edition Service Pack 2
  • Windows Server 2003 Service Pack 2
  • Windows Server 2003 x64 Edition Service Pack 2
  • Windows Server 2003 with SP2 for Itanium-based Systems
  • Windows Vista Service Pack 2
  • Windows Server 2008 for Itanium-based Systems Service Pack 2
  • Windows 7 for 32-bit Systems
  • Windows 7 for 32-bit Systems Service Pack 1
  • Windows 7 for x64-based Systems
  • Windows 8 for 32-bit Systems
  • Windows 8 for 64-bit Systems
  • Windows Server 2012
  • Windows RT
  • Windows Server 2008 R2 for x64-based Systems (Server Core installation)
  • Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)
  • Windows XP Service Pack 3
  • Windows Vista x64 Edition Service Pack 2
  • Windows Server 2008 for 32-bit Systems Service Pack 2
  • Windows Server 2008 for x64-based Systems Service Pack 2
  • Windows 7 for x64-based Systems Service Pack 1
  • Windows Server 2008 R2 for x64-based Systems
  • Windows Server 2008 R2 for x64-based Systems Service Pack 1
  • Windows Server 2008 R2 for Itanium-based Systems
  • Windows Server 2008 R2 for Itanium-based Systems Service Pack 1
  • Windows Server 2012 (Server Core installation)

Featured Stories

Connect with us on