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Agent Installation and Management Guide

The Agent Installation Guide contains information about the Worry-Free Remote Manager (WFRM) agent 
installation process and step-by-step instructions for installing the WFRM agents on 
• Client Server Security (CS) versions 3.5 or 3.6
• Client Server Messaging Security (CSM) versions 3.5 or 3.6
• Worry-Free Business Security (WFBS) (formally CS) version 5.0
• Worry-Free Business Security Advanced (WFBS-A) (formally CSM) version 5.0

Note: The above products will be collectively referred to as "managed server(s)" in this document.

Agent GUID
To distinguish between WFRM agents, WFRM assigns a globally unique identifier (GUID) to each agent. The 
person who installs the agent program on the managed server must input the GUID during installation to allow the 
agent program to register to the console. This GUID is always available under Customers > My Customers > 
{customer} > {customer domain} (all on the tree on the left) > Domain Profile (on the right)

Example of a WFRM agent GUID:

4F6F0F8697C9-A1FFCF63-D833-84D9-1C35

Installing the Agent

Note: Typically, the network administrator on the managed network handles the agent installation. Provide these 
instructions to the network administrator with all the necessary information (This information is also included in 
the "Trend Micro Worry-Free Remote Manager Agent Installation Guide").

Worry-Free Remote Manager monitors and manages protected networks. It does this by communicating with an 
agent that is installed on servers on the managed network. The performance of WFRM depends highly on the 
proper installation and health of the agent.
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Before installing the agent, you will need the following:
• The customer and domain must have already been registered on the WFRM server.
• Agent GUID (available from the reseller on the Domain Profile under Customers > My Customers > 

{customer name} > {customer domain} on the WFRM console)
• Agent installer (WFRMAgentforCSM.exe)
• The fully qualified domain name (FQDN) of the Worry-Free Remote Manager server. The FQDN varies in each 

region as follows:

Asia Pacific - wfrm-apaca.trendmicro.com
Europe and the Middle East - wfrm-emeaa.trendmicro.com
Latin America - wfrm-lara.trendmicro.com
North America - wfrm-usa.trendmicro.com

The managed server must meet the following requirements:
• CS/CSM 3.5/3.6 or WFBS/WFBS-A 5.0
• Active Internet connection
• 50MB available hard disk space

To install the agent:

1. Copy the Agent installation file (WFRMAgentforCSM.exe) to the managed server (you should have received a 
link to this file when you signed up to use the WFRM service).

2. Open the installation file.
3. The InstallShield Wizard welcome screen opens. Click Next.
4. The License Agreement screen opens. Read the license agreement carefully. If you disagree with the terms of 

the license agreement, click Cancel to exit the installation. If you agree with the terms, click I accept the terms 
of the license agreement and click Next.

5. Provide your name and the name of your company and click Next. A pop-up opens informing you of the 
managed server version and the Agent version. Click OK.

6. The Installation Location screen opens. To use the default location, click Next.
7. Provide the FQDN of the Worry-Free Remote Manager server that corresponds to your region in the Server 

address field.
8. Select a communication protocol and port:

• For HTTP, use port 80 (Do not click HTTP authentication; it is not being used at this time). Click Next.
• For HTTPS (recommended), use port 443. Enter the path and filename of the SSL certificate or click the 

Browse button to locate the SSL certificate (see Using Internet Explorer 6 to Obtain the SSL Certificate on page 
2-3 or Using Internet Explorer 7 to Obtain the SSL Certificate on page 2-3). Click Next.

9. If the managed server uses a proxy server to connect to the Internet, specify the necessary settings. Click Next.
10. Type the GUID (see Agent GUID on page 2-1). Click Next.
11. Review the installation settings and click Next.
12. Click Finish to close the wizard after installation completes.

If the installation is successful and settings are correct, the agent should automatically register to the Worry-Free 
Remote Manager  server. The agent should show as online on the WFRM console.

See Using Internet Explorer 6 to Obtain the SSL Certificate on page 3 and Verifying Agent/Server Connectivity on page 5 for 
installation issues.
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Note: To remove the agent, see Removing the Agent on page 8

Using Internet Explorer 6 to Obtain the SSL Certificate
To obtain the SSL certificate using Internet Explorer 6:

1. Open Internet Explorer then go to https://wfrm.trendmicro.com/.
2. Double-click the padlock icon on the status bar. This opens the Certificate window showing the certificate 

issued to *.trendmicro.com.
3. Click the Certification Path tab > Equifax Secure Certificate Authority > View Certificate.
4. When the Certificate window showing Certificate Information Authority opens, click the Details tab.
5. Click Copy to File > Next and then select DER encoded binary X.509 (.CER).
6. Click Next, and then type the path and filename of the certificate (example: wfrmcert.cer).
7. Click Next > Finish.

Using Internet Explorer 7 to Obtain the SSL Certificate
To obtain the SSL certificate using Internet Explorer 7:

1. Open Internet Explorer then go to https://wfrm.trendmicro.com/.
1. Click the padlock icon to the right of the address bar. You will see the Web site identification menu.
2. Click View Certificates. This opens the Certificate window showing the certificate issued to 

*.trendmicro.com.
3. Click the Certification Path tab > Geotrust > View Certificate.
4. When the Certificate window showing Certificate Information Authority opens, click the Details tab.
5. Click Copy to File > Next and then select DER encoded binary X.509 (.CER).
6. Click Next, and then type the path and filename of the certificate (example: wfrmcert.cer).
7. Click Next > Finish.

Verifying Agent Installation
There are three methods for verifying that the WFRM agent has been installed correctly and is operating properly. 
Check:
• Agent service
• Start menu shortcuts
• System tray icon
3
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Agent Service
Check if "Trend Micro Information Center for CSM" is started.
1. Click Start > Settings > Control Panel > Administrative Tools > Services

2. Look for Trend Micro Worry-Free Remote Manager Agent
3. Check if the Status is Started

Start Menu Shortcuts
Check the Program Group in the Start Menu.
1. Click Start > All Programs > Information Center for CSM

2. Verify that the Program Group contains the following items:
• Readme
• Remove Worry-Free Remote Manager Agent for CSM
• Agent Configuration Tool

System Tray Icon
Check for the WFRM agent icon in the system tray. If for any reason the icon is not visible, you can start it by 
clicking Start > Programs > Worry-Free Remote Manager Agent > Agent Configuration Tool.

Exiting the tool does not stop the WFRM service. It only closes the Configuration Tool and removes the icon from 
the task bar. The tool can be restarted at any time.

Suspend the mouse over the icon for status information (see See Agent Status Messages on page 6).

ICON MEANING

A green icon indicates that the Agent is connected to WFRM’s communication server.

A red icon indicates that the Agent isn’t connected to WFRM’s communication server or the ver-
sion of the Agent is mismatched with the server and needs to be updated.

An icon with a red arrow indicates that the Agent has logged off from WFRM
4
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Verifying Agent/Server Connectivity
To ensure that the Worry-Free Remote Manager service is running smoothly, make sure that agents are online.

To view the status of agents:

1. Log on to the WFRM Web console.
2. Click the Customers tab and ensure that My Customers is selected in the left pane.
3. Click the All Agents tab in the right pane. The tab lists the status of each agent in the Status column. For details 

on each status, See Agent Status Messages on page 6

Installation Errors
The agent installation logs cover agent installation activities. Collect these logs and send them to your service 
support provider if you encounter problems during installation. The agent installation logs can be obtained from the 
following location on the managed server:

C:\TMICAgentForCSM_Install.log

See Troubleshooting on page 7 for further information.
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Agent Status Messages
On the managed server, the agent displays a system tray icon (either ,  or  ). Whenever you move your 
mouse over the system tray icon, it displays a status message that indicates whether the agent is functioning 
normally. See the table below to understand the status messages and how you can address them.

Message Unknown error encountered. Check the system or restart the agent.

Description Unexpected errors—typically system errors—are preventing the agent from functioning prop-
erly.

Resolution Check the managed server for low memory or other system problems.

Message Unable to register with the remote server.

Description The GUID you provided may be wrong.

Resolution Verify that you have used the correct GUID. If necessary, reinstall the agent using the correct 
GUID.

Message Unable to connect to the remote server.

Description The managed server may be experiencing Internet connectivity problems.

Resolution Check Internet connectivity on the managed server. Also, check the agent’s proxy settings and 
the specified server address and port.

Message Agent disabled by Worry-Free Remote Manager.

Description The agent has been temporarily disabled through the Worry-Free Remote Manager console.

Resolution Enable the agent through the Worry-Free Remote Manager console.

Message Agent does not match the CS/CSM version. Install the correct agent version.

Description The CS/CSM and agent versions do not match.

Resolution Upgrade the CS/CSM server to the latest version and install the latest agent.

Message Agent service stopped.

Description The agent service has been stopped.

Resolution Start the agent service by right-clicking the agent system tray icon and clicking Start Service.

Message Unable to load components. You may need to reinstall the agent.

Description The agent encountered problems while loading some components.

Resolution First try restarting the agent service by right-clicking the agent system tray icon and clicking 
Restart Service or Start Service. If this does not work, uninstall and then reinstall the agent. 
Make sure you use the same GUID.

TABLE 2-1.   Status messages displayed by the agent’s system tray icon
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Troubleshooting

Agent does not match the CS/CSM version
After installing the WFRM Agent on the managed server, you get the following error message:

Agent does not match the CS/CSM version. Install the correct agent version.

This happens because of either of the following:
1. Your CS/CSM build is not supported by WFRM. The following builds are required:

• For CS/CSM 3.5, the required build is 1113 or higher.
• For CS/CSM 3.6, the required build is 1095 or higher.
To check the build number, open the CS/CSM Security Dashboard and go to Help > About. You can then 
download the supported CS or CSM build from the Update Center and install it on the server.

2. The WFRM Agent is downloading the latest program upgrade from the WFRM Server. This may take 2-3 
minutes. After downloading is done, the WFRM Agent icon will return to normal (green).

Note: WFRM supports all versions of WFBS/WFBS-A 5.0, so the above issue does not apply to WFBS/WFBS-A 5.0.

Unable to connect to the server
The following error message shows up when you click the Test Connection button in the Agent Configuration 
Tool of WFRM:

"Unable to connect to the server. It may be invalid settings. Enter valid settings and try again."

There are three possible reasons for this:
• The managed server cannot connect to the Internet. Make sure CS/CSM or WFBS-WFBS-A can access the 

Internet.
• The Worry-Free Remote Manager Server address is incorrect. Make sure the FQDN of the Worry-Free Remote 

Manager Server is correct.
Use the FQDN that corresponds to your region:
• Asia Pacific: wfrm-apaca.trendmicro.com
• Europe/Middle East: wfrm-emeaa.trendmicro.com
• Latin America: wfrm-lara.trendmicro.com
• North America: wfrm-usa.trendmicro.com

• If the Security Server uses a proxy server to connect to the Internet, make sure the proxy and user authentication 
settings are correctly configured.

Unable to register with the remote server
"Unable to register with the remote server" shows up when the mouse is moved over the Worry-Free Remote 
Manager agent icon

This happens when the Globally Unique Identifier (GUID) is incorrect.
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To fix this issue:

1. Go to C:\Program Files\Trend Micro\WFRMAgentForCSM.
2. Open the AgentSysConfig.xml file using a text editor.
3. Look for the GUID between the parameters "<AgentGUID>" and "</AgentGUID>".
4. Edit the GUID and then save the file.
5. In the same folder, open the csmSysConfig.xml file using a text editor.
6. Look for the GUID between the parameters "<ProductGUID>" and "</ProductGUID>".
7. Edit the GUID and then save the file.
8. Right-click the Worry-Free Remote Manager Agent icon on the task bar and then click Restart Service.

Removing the Agent
There are three ways to remove the agent locally (it can also be removed by the reseller via the WFRM console):
1. Directly uninstall the WFRM Agent
2. Uninstall the WFRM Agent via the Control Panel
3. Uninstall the WFRM Agent manually

Note: When removing the agent locally, the agent will unregister from Worry-Free Remote Manager which automatically 
deletes all data associated with the agent. To prevent the agent from unregistering, modify the Server address value 
on the agent interface before removing the agent.

Directly uninstall the WFRM Agent:
1. Open the WFRM Agent installation file.
2. The installation wizard will prompt you to confirm the uninstallation. Click Yes.

Note: During removal, you will be prompted to close certain applications. Close these applications and click Retry to 
continue.

3. Click Finish to close the wizard after the uninstallation is complete.

Uninstall the WFRM Agent via the Control Panel
1. Open the Control Panel’s Add or Remove Programs applet.
2. Select Worry-Free Remote Manager Agent and then click the Change/Remove button.
8
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Uninstall the WFRM Agent manually
If for any reason the agent cannot be removed through standard ways, perform the following steps to manually 
remove it:
1. Stop the Trend Micro Worry-Free Remote Manager Agent service

a. Click Start > Run.

b. Type "cmd" on the command line and then press the Enter key.

c. Run this command:

net stop Trend Micro Worry-Free Remote Manager Agent
2. Remove the Trend Micro Worry-Free Remote Manager Agent service.

a. On the command line, use the change directory (cd) command to go to the WFRM Agent directory.

b. Run this command:

TMICAgent -u
3. Remove the program files.

Delete [agent install directory] – WFRMAgentForCSM
4. Open the Registry Editor (regedit.exe) and remove the following registry keys:

Note: Always create a backup before modifying the registry. Incorrect registry changes may cause serious issues. Should 
this occur, restore it by referring to the "Restoring the Registry" Help topic in Regedit.exe or the "Restoring a 
Registry Key" Help topic in Regedt32.exe.

HKEY_LOCAL_MACHINE\SOFTWARE\TrendMicro\TMIC4CSM\Agent\..

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\ 
23FC8F347B51DD440AD13A73D13A73D22D58E6

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
Installer\UserData\S-1-5-18\Products\
23FC8F347B51DD440AD13A73D13A73D22D58E6

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
Uninstall\{43F8CF32-15B7-44DD-A01D-A3372DD2856E}

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
Uninstall\InstallShield Uninstall Information\
{43F8CF32-15B7-44DD-A01D-A3372DD2856E}

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
Uninstall\InstallShield_\{43F8CF32-15B7-44DD-A01D-A3372DD2856E}

5. Remove the WFRM Agent shortcut from the Start menu.
a. On the desktop, click My Computer.
a. Change the current directory to ..\Documents and Settings\All Users\

Start Menu\Programs.

Delete the Worry-Free Remote Manager Agent folder.
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